PHPは5.3~5.6に対応

CS-CartはPHPで記述されたソフトウェアであり、PHPが動作するサーバー環境が必要となります。
現時点ではPHP5.3、5.4、5.5、5.6に対応しています。
※Version4.3系ではPHP5.6の利用を推奨
※Version4.2系まではPHP5.3、5.4にのみ対応


データベースはMySQL4.1以上が必要

CS-Cartでは商品や顧客など、ほとんど全ての情報をMySQLデータベースに格納します。
現時点ではMySQL4.1以上が必要となります。


動作環境詳細

OS

  • Linux / FreeBSD / RedHat などのUNIX系OS
  • mod_security の無効化
  • .htaccess ファイルにおいて DirectoryIndex、Deny、Allow、Options、Order、AddHandler、RewriteEngine、RewriteBase、RewriteCond、RewriteRule を利用可能にする

PHP

  • PHP version 5.3、5.4、5.5、5.6
  • safe_mode の無効化
  • cURL の有効化
  • GDライブラリ の有効化
  • mbstring の有効化
  • ftp_connect の有効化
  • file_uploads の有効化
  • Phar 拡張モジュール の有効化
  • ZipArchive 拡張モジュール の有効化

MySQL

  • MySQL version 4.1以上

ユーザー閲覧用Webブラウザ

  • Internet Explorer 9以上
  • Mozilla Firefox の最新バージョン
  • Apple Safari の最新バージョン
  • Google Chrome の最新バージョン

※ 管理画面は各種スマートフォンおよびタブレット端末での利用を想定していません。PCまたはMacでのアクセスが必要です。

フィードバック

お役に立ちましたか?

はい いいえ
お役に立ちましたか
理由をお聞かせください
フィードバックありがとうございました

このトピックへフィードバック

送信